About this forum Any questions or feedback on what this forum is or how this forum operates.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1   Report Post  
Old January 31st 06, 10:27 AM
Junior Member
 
First recorded activity by DIYBanter: Jan 2006
Posts: 1
Default Vertical Immersion Heater Thermostat Problem

Since the middle of November I have had to have four immersion heaters fitted as the thermostat goes. One lasted for two weeks, one for four weeks but the second of them and now the present one have only lasted for one week. No fuses blow and rather than keep changing the whole unit I have now purchased just the thermostat.

The heater only heats the water for the bathroom and there is no gas involved and the timer is on "constant".

The electrician who fitted the first three also changed the cable from the timer to the element.

After the third thermostat went I got another electrician in and he put his tester thing here and there and said that the power was all O.K., changed the thermostat but its gone again.

Obviously I am concerned mainly from a safety point of view so could anyone help please?

Reply
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules

Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
immersion thermostat still playing up Russ UK diy 11 January 11th 06 08:42 AM
Immersion Water Heater Problem Tim W. UK diy 1 March 27th 05 12:33 AM
Immersion Heater Problem Tim W. UK diy 0 March 26th 05 08:40 PM
Immersion Heater Problem [email protected] UK diy 8 January 3rd 04 04:36 PM
Immersion Heater Fuse Blowing MrCheerful UK diy 3 July 24th 03 02:15 PM


All times are GMT +1. The time now is 10:48 PM.

Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright 2004-2019 DIYbanter.
The comments are property of their posters.
 

About Us

"It's about DIY & home improvement"

 

Copyright © 2017