Home Repair (alt.home.repair) For all homeowners and DIYers with many experienced tradesmen. Solve your toughest home fix-it problems.

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
  #1   Report Post  
Posted to alt.home.repair
external usenet poster
 
Posts: 28
Default Hoover WindTunnel agaitator will not spin

This is a problem with which I have been struggling in this model
(U6425-920) since very early after I bought it... The agitator will
spin intermittently and some rubber smell will be noticeable.

The brush roll is new (and without any hair within).
The flat belt (P/N 38528035) is new.
The V belt (P/N 38528034) was replaced about 4 months ago.

The manual says "The V-belt is designed to last for a long time and is
not normally replaced".

These are the only replaceble things I can think of.

How do I troubleshoot the problem?

Is it possible that the Flat belt and the V-belt must always be
replaced at the same time, to minimize the chance that one is damaging
the other?

Any ideas except for throwing out this vacuum cleaner and buying...
buying what actually? (nowadays everything is made cheap and
unreliable)

Thanks!
Sam

  #2   Report Post  
Posted to alt.home.repair
external usenet poster
 
Posts: 12
Default Hoover WindTunnel agaitator will not spin


wrote:
This is a problem with which I have been struggling in this model
(U6425-920) since very early after I bought it... The agitator will
spin intermittently and some rubber smell will be noticeable.


The manual says "The V-belt is designed to last for a long time and is
not normally replaced".


Ah, I see Hoover only hires the best marketing BSers ;-)

From what I've read, the V-belt should be replaced every 3-4 months

with normal use. The "not normally replaced" in your manual is Hoover
hoping you'll only use the vacuum once a month or so (if that).

I just picked up a pack of V-belts today for my mother. She lives in
the middle of nowhere and I live in the big city. Several months ago
her 25 year old Electrolux died and she asked me to shop around for a
vacuum and bring it to her the next time I visited. I go shopping and
talk to her a few weeks later - turns out she's driven 60 miles to the
nearest Sears and bought this Hoover POS. I knew she was in trouble
right then and asked her to take it back, but she wanted to stick with
it (stubborn old folk syndrome). Non-stop trouble since then. Belts
stretching, belts thrown, burning smells, clogs (on the vacuum, of
course, not my mother ;-) Sheesh.

My advice? Buy yourself what I was planning on buying for her - a
Riccar 8955 for an upright, or a Miele if you'd like a canister.
Either *will* cost more than the Hoover, but they are unlikely to burn
your house down or fall on their face every week. When my mother
finally tires of this Hoover thing, I'm off for a Riccar.

Good luck!

  #3   Report Post  
Posted to alt.home.repair
Art Art is offline
external usenet poster
 
Posts: 788
Default Hoover WindTunnel agaitator will not spin

I have a hoover windtunnel powerhead for our central vac. Gets tons of use
and has been perfect for several years. Changed belt and bristle roller
once during that time.


"Squirrel" wrote in message
ups.com...

wrote:
This is a problem with which I have been struggling in this model
(U6425-920) since very early after I bought it... The agitator will
spin intermittently and some rubber smell will be noticeable.


The manual says "The V-belt is designed to last for a long time and is
not normally replaced".


Ah, I see Hoover only hires the best marketing BSers ;-)

From what I've read, the V-belt should be replaced every 3-4 months

with normal use. The "not normally replaced" in your manual is Hoover
hoping you'll only use the vacuum once a month or so (if that).

I just picked up a pack of V-belts today for my mother. She lives in
the middle of nowhere and I live in the big city. Several months ago
her 25 year old Electrolux died and she asked me to shop around for a
vacuum and bring it to her the next time I visited. I go shopping and
talk to her a few weeks later - turns out she's driven 60 miles to the
nearest Sears and bought this Hoover POS. I knew she was in trouble
right then and asked her to take it back, but she wanted to stick with
it (stubborn old folk syndrome). Non-stop trouble since then. Belts
stretching, belts thrown, burning smells, clogs (on the vacuum, of
course, not my mother ;-) Sheesh.

My advice? Buy yourself what I was planning on buying for her - a
Riccar 8955 for an upright, or a Miele if you'd like a canister.
Either *will* cost more than the Hoover, but they are unlikely to burn
your house down or fall on their face every week. When my mother
finally tires of this Hoover thing, I'm off for a Riccar.

Good luck!



  #4   Report Post  
Posted to alt.home.repair
external usenet poster
 
Posts: 557
Default Hoover WindTunnel agaitator will not spin

On 7 Dec 2006 15:51:16 -0800, "
wrote:

This is a problem with which I have been struggling in this model
(U6425-920) since very early after I bought it... The agitator will
spin intermittently and some rubber smell will be noticeable.

The brush roll is new (and without any hair within).
The flat belt (P/N 38528035) is new.
The V belt (P/N 38528034) was replaced about 4 months ago.

The manual says "The V-belt is designed to last for a long time and is
not normally replaced".

These are the only replaceble things I can think of.

How do I troubleshoot the problem?

Is it possible that the Flat belt and the V-belt must always be
replaced at the same time, to minimize the chance that one is damaging
the other?

Any ideas except for throwing out this vacuum cleaner and buying...
buying what actually? (nowadays everything is made cheap and
unreliable)

Thanks!
Sam



Sounds like a loose belt. If it's close to purchase date when you had
problems, contact the manufacturer for guidance.

later,

tom @ www.FreeWorkAtHomeIdeas.com

Reply
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules

Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hoover Windtunnel Vacuum problems [email protected] Home Ownership 2 June 5th 06 04:24 PM
Hoover vacuum Patt Home Repair 2 March 6th 06 11:04 PM
Hoover Windtunnel powerhead cord repair Mike Trachtenberg Home Repair 1 February 19th 06 09:12 PM
Hoover SteamVac V2 6-Brush WidePath Brushes Don't Spin Orlanzo Ross Home Repair 4 October 7th 05 01:49 PM
Hoover 1300 SE Awash performance - no fast spin bengee UK diy 14 April 3rd 04 10:42 AM


All times are GMT +1. The time now is 05:43 AM.

Powered by vBulletin® Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.
Copyright 2004-2023 DIYbanter.
The comments are property of their posters.
 

About Us

"It's about DIY & home improvement"